UCF STIG Viewer Logo

The version of Microsoft Edge running on the system must be a supported version.


Overview

Finding ID Version Rule ID IA Controls Severity
V-235758 EDGE-00-000045 SV-235758r626523_rule High
Description
Security flaws with software applications are discovered daily. Vendors are constantly updating and patching their products to address newly discovered security vulnerabilities. Organizations (including any contractor to the organization) are required to promptly install security-relevant software updates (e.g., patches, service packs, and hot fixes). Flaws discovered during security assessments, continuous monitoring, incident response activities, or information system error handling must also be addressed expeditiously. Organization-defined time periods for updating security-relevant software may vary based on a variety of factors including, for example, the security category of the information system or the criticality of the update (i.e., severity of the vulnerability related to the discovered flaw). This requirement will apply to software patch management solutions that are used to install patches across the enclave and also to applications themselves that are not part of that patch management solution. For example, many browsers today provide the capability to install their own patch software. Patch criticality, as well as system criticality will vary. Therefore, the tactical situations regarding the patch management process will also vary. This means that the time period used must be a configurable parameter. Time frames for application of security-relevant software updates may be dependent upon the Information Assurance Vulnerability Management (IAVM) process. The application will be configured to check for and install security-relevant software updates within an identified time period from the availability of the update. The specific time period will be defined by an authoritative source (e.g., IAVM, CTOs, DTMs, and STIGs).
STIG Date
Microsoft Edge Security Technical Implementation Guide 2022-06-17

Details

Check Text ( C-38977r626470_chk )
Cross-reference the build information displayed with the Microsoft Edge site to identify, at minimum, the oldest supported build available.

If the installed version of Edge is not supported by Microsoft, this is a finding.
Fix Text (F-38940r626471_fix)
Install a supported version of Edge.